selfhtml.de - Alles für den Webmaster!

 

Empfehlung:

wix.com

Kostenlose Homepage

Besuchen Sie auch:

Jobs:

an Tobias

Autor: Dackel2
Datum: 24.04.2012 11:49:35

Hallo Tobias,

ich brauche nochmal Deine Hilfe. Seit Tagen probiere ich rum aber es klappt nicht mehr. Du hattest mir ja schon eine Anleitung gegeben aber irgendwie hakt es noch. Es geht ja darum, die Quicktimefilme, die mit IWEB erstellt wurden so zu wandeln, daß die von den anderen Browsern auch gelesen werden können.

Folgendes funktioniert : 1. die Umwandlung mit HTML5 (einwandfrei)
                                      2. die Editierung mit Textwrangler (einwandfrei)
                                      3. die Erhaltung der in IWEB vorgenommenen
                                          Platzierung der Filme.

Folgendes funktioniert nicht: 1. die Anzeige der Filme in den neuen Formaten.

Komischerweise hat das zu Beginn ( das teilte ich Dir ja auch schon mit) einmal funktioniert. Aber nun werden zwar die richtigen Positionen angezeigt  -der Anzeigebalken der neuen Formate steht an der richtigen Stelle-, aber das Filmbild (der Film) wird nicht angezeigt.

Auch kann ich den am MAC angezeigten Film ein/ausschalten , indem "write Movie1" aktiviert oder deaktiviert wird, aber die Filme aus der Wandlung werden nicht angezeigt, nur der zugehörige Balken.

nun folgt das betreffende HTML-Dokument :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">


<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de">
  <head>
    <meta http-equiv="Content-type" content="text/html; charset=UTF-8" />
    <meta name="Generator" content="iWeb 1.1.1" />
    <title>Probeseite</title>
    <link rel="stylesheet" type="text/css" media="screen" href="Probeseite_files/Probeseite.css" /><script type="text/javascript" src="Probeseite_files/Probeseite.js"></script>
  </head>
  <body style="background: #f90327; margin: 0pt; " onload="onPageLoad();">
    <div style="text-align: center; ">
      <div style="margin-bottom: 0px; margin-left: auto; margin-right: auto; margin-top: 0px; overflow: hidden; position: relative;  background: #fef9f7; text-align: left; width: 980px; " id="body_content">
        <div style="float: left; height: 0px; line-height: 0px; margin-left: 0px; position: relative; width: 0px; z-index: 10; " id="header_layer">
          <div style="height: 0px; line-height: 0px; " class="tinyText"> </div>
        </div>
        <div style="float: left; height: 0px; line-height: 0px; margin-left: 0px; position: relative; width: 0px; z-index: 15; " id="footer_layer">
          <div style="height: 0px; line-height: 0px; " class="tinyText"> </div>
        </div>
        <div style="float: left; margin-left: 0px; position: relative; width: 700px; z-index: 0; " id="nav_layer">
          <div style="height: 0px; line-height: 0px; " class="tinyText"> </div>
        </div>
        <div style="margin-left: 0px; position: relative; width: 980px; z-index: 5; " id="body_layer">
          <div style="height: 0px; line-height: 0px; " class="tinyText"> </div>
          <div class="graphic_generic_title_textbox_style_default" style="height: 49px; left: 35px; position: absolute; top: 22px; width: 630px; z-index: 1; " id="id1">
            <div style="height: 0px; line-height: 0px; " class="tinyText"> </div>
          </div>
          <script type="text/javascript"><!--
>writeMovie1();
--></script>


<div style="position:relative;width:480px;height:270px;"><video controls="controls"  autoplay="autoplay" poster="Baum.files/Baum.jpg" width="480" height="270"  onclick="if(/Android/.test(navigator.userAgent))this.play();"
{
    document.write('<object id="id2" classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" codebase="http://www.apple.com/qtactivex/qtplugin.cab" width="480" height="286" style="height: 286px; left: 250px; position: absolute; top: 205px; width: 480px; z-index: 1; "><param name="src" value="Probeseite_files/QTPlaceholder.mov" /><param name="qtsrc" value="Baum.mp4" /><param name="controller" value="true" /><param name="autoplay" value="false" /><param name="scale" value="tofit" /><param name="volume" value="100" /><param name="loop" value="false" /><embed pluginspage="http://www.apple.com/quicktime/download/" type="video/quicktime" class="mov" width="480" height="286" src="Probeseite_files/QTPlaceholder.mov" qtsrc="Baum.mp4" controller="true" autoplay="false" scale="tofit" volume="100" loop="false"></embed></object>');
}




<source src="Baum.files/Baum.mp4" type="video/mp4" />

<source src="Baum.files/Baum.webm" type="video/webm" />

<source src="Baum.files/Baum.ogv" type="video/ogg" />

<object type="application/x-shockwave-flash" data="Baum.files/flashfox.swf" width="480" height="270" style="position:relative;">

<param name="movie" value="Baum.files/flashfox.swf" />

<param name="allowFullScreen" value="true" />

<param name="flashVars" value="autoplay=true&controls=true&loop=true&src=Baum.mp4" />

<embed src="Baum.files/flashfox.swf" width="480" height="270" style="position:relative;"  flashVars="autoplay=true&controls=true&loop=true&poster=Baum.files/Baum.jpg&src=Baum.mp4" allowFullScreen="true" wmode="transparent" type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer_en" />

<img alt="Baum" src="Baum.files/Baum.jpg" style="position:absolute;left:0;" width="480" height="270" title="Video playback is not supported by your browser" />

</object>

</video></div>

<script src="Baum.files/html5ext.js" type="text/javascript"></script>

<a style="display:none" href="http://easyhtml5video.com">html5 video stream by EasyHtml5Video.com v1.5.1m</a>





          <div class="graphic_textbox_style_default" style="height: 100px; left: 427px; position: absolute; top: 74px; width: 373px; z-index: 1; " id="id3">
            <div>
              <div class="graphic_textbox_layout_style_default">
                <div class="paragraph Body" style="line-height: 89px; margin-bottom: 0px; margin-top: 0px; padding-bottom: 0pt; padding-top: 0pt; color: #48fe33; font-size: 64px; line-height: 89px; opacity: 1.00;">Test</div>
              </div>
            </div>
          </div>
          

<img src="Probeseite_files/shapeimage_1.png" alt="Platzierungsende" title="" id="id4" style="height: 102px; left: 228px; position: absolute; top: 534px; width: 523px; z-index: 1; " />
          <div style="height: 1480px; line-height: 1480px; " class="tinyText"> </div>
        </div>
      </div>
    </div>
  </body>
</html>

Hierbei ist das Movie1 im Moment ausgeschaltet, wird also am Mac nicht angezeigt, sondern nur der Balken, ebenso am PC.  Wie schon beschrieben, funktioniert mit dem obigen Dokument alles, nur die Anzeige der Film-Formate aus der Wandlung nicht (also MPEG-4,JPEG, Webm und OGV ).

Die zugehörigen Icons (die Filmdateien) der Formate aus der Wandlung wurden auch in den Ordner "Film_files" des Original-Film´s gebracht, sodaß ein Zugriff möglich ist. Dort stehen nun also die Dateien des Original-Quicktimefilm´s und die Dateien der 4 neuen Formate.

Alles ist also so wie zu Beginn, als vor Tagen die Anzeige aller Film-Formate funktionierte, nur war damals die Platzierung noch nicht richtig. Daraufhin hattest Du ja empfohlen die Platzierungsanweisungen aus dem Original-JS in das modifizierte Dokument einzusetzen  ( es genügt aber nicht, den von Dir genannten Teil "Style" einzusetzen, sondern es muß die gesamte Zeile sein, womit das dann funktioniert. Das ist der komplexe Block im Document.) Dieses Problem wäre also beseitigt, aber nun werden die neuen Filme nicht angezeigt.

Woran kann das liegen ? Wie heißt denn der Befehl, welcher für die Anzeige der Filme notwendig ist ?

Besten Dank im Voraus, für Deine umgehende Antwort

Gruß Suki



Re: an Tobias

Autor: Dackel2
Datum: 24.04.2012 12:02:08

Hallo Tobias,
ich vergaß noch zu sagen, daß das gleiche Problem weiter besteht, auch wenn der Teil mit "Movie1" völlig gelöscht ist. Es ist dann das Filmbild am MAC nicht mehr zu sehen, sondern nur --wie zuvor mit MAC-Anzeige--noch der
Balken für die neuen Formate.  Sobald  "writeMovie1" eingeschaltet ist wird
der Quicktime-Balken von dem neuen Balken überlagert  und man könnte meinen, daß es nun funktioniert, tatsächlich ist aber das Quicktime-Bild vorhanden, nicht das Bild der neuen Formate. Der Balken der neuen Formate überdeckt dann lediglich den Quicktime-Balken

Beste Grüße Suki

------------------------------------------------
Fullquote gelöscht -- Freddy



[OT] Hinweis (was:Re: an Tobias)

Autor: reporter
Datum: 24.04.2012 14:00:18

Hallo,

bitte zietiere nicht den vollständigen Beitrag sondern nur auf die Textstellen, auf den du dich beziehst. Auf lange Sicht erschwert es die Lesbarkarkeit.



[OT] Netiquette (was: an Tobias)

Autor: Freddy
Datum: 24.04.2012 14:51:28

Hallo,

bitte lese Dir einmal die Netiquette durch. Sie wurde nicht umsonst von den Usern "selfhtml.de"s verfasst:

http://www.sve-fre.de/selfhtml/netiquette
http://www.sve-fre.de/selfhtml/netiquette/index.php?a=text7_0#text7_0


Darauf haben reporter und ich Dich schon einmal hingewiesen:

http://www.selfhtml.de/forum/zeigebeitrag_8_135266_135231_0.php
http://www.selfhtml.de/forum/zeigebeitrag_8_135269_135231_0.php


Freddy



Re: [OT] Hinweis

Autor: dzalok
Datum: 24.04.2012 15:22:41


> bitte zietiere nicht den vollständigen Beitrag
> sondern nur auf die Textstellen, auf den du dich
> beziehst.

Wobei ich jetzt in diesem Fall - als Neueinsteiger in diesem Forum - es jetzt nicht so schlimm fand, das das Posting so groß ausgefallen ist.

Warum nur habe ich so lange dieses Forum nicht entdeckt ??

Schön wäre noch, wenn der einzelne User ein paar Zeilen über sich hinschreiben könnte, so das die Postings wie in anderen Foren am Ende noch eine kleine Fußzeile mit ein paar persönlichen Dingen vom Verfasser hat. Also z.B. er mag gerne Ski Fahren, oder sitzt den ganzen Tag vorm PC, spielt Golf oder geht gerne Urlaub im Schwarzwald machen, das nur mal so als Anregung !!



Re: [OT] Hinweis

Autor: Dackel2
Datum: 24.04.2012 16:34:11

>
> > bitte zietiere nicht den vollständigen
> Beitrag
Hallo,
ich habe nichts zitiert, sondern die umfangreichen Angaben sind nach meiner Ansicht zum Verständnis des Ganzen notwendig. Ich hatte schon mit Tobias Kontakt und hoffe auf seine baldige Antwort.

Gruß Suki



Re: [OT] Hinweis

Autor: Freddy
Datum: 24.04.2012 17:13:14

Hallo,

> ich habe nichts zitiert, sondern die
> umfangreichen Angaben sind nach meiner Ansicht
> zum Verständnis des Ganzen notwendig. Ich hatte
> schon mit Tobias Kontakt und hoffe auf seine
> baldige Antwort.

Doch, hast Du. Ich habe Dein Fullquote ja selbst gelöscht. Mit "nur zitieren, auf was Du Dich beziehst" meinen wir übrigens, dass Du im Antwortformular nicht den gesamten Text des Vorredners übernehmen sollst (und schon gar nicht Grußformeln oder Anreden), sondern nur die Passagen, auf die Du eben antwortest, wie beispielsweise Fragen.
Jeder hat die Möglichkeit, das gesamte Posting des Vorredners anzuklicken. Zudem verschlechtert es die Suchergebnisse und bläht die DB unnötig auf, abgesehen von der verschlechterten Lesbarkeit der Beiträge.

Ist ja nicht weiter tragisch, macht nur keinen Spaß "hinterherzuputzen". :-)

BTW: Bei den Suchergebnissen kann ich mir unter dem Titel "an Tobias" nicht wirklich etwas vorstellen, also hat auch die "Regel" ihre Berechtigung, sinnvolle Themenbeschreibungen zu verwenden.


Gruß,
Freddy



Re: [OT] Hinweis

Autor: Dackel2
Datum: 24.04.2012 18:58:40

Spaß "hinterherzuputzen". :-)
>
> BTW: Bei den Suchergebnissen kann ich mir unter
> dem Titel "an Tobias" nicht wirklich etwas
> vorstellen, also hat auch die "Regel" ihre
> Berechtigung, sinnvolle Themenbeschreibungen zu
> verwenden.
>
>
> Gruß,
> Freddy

Hallo Freddy,
ich habe an Tobias geschrieben weil der mir recht freundlich und vor allem kompetent geantwortet hat.

Also was ist nun, Tobias scheint nicht da zu sein. Bekomme ich evtl. von Euch eine Antwort auf meine wichtige Frage ?

Übrigens habe ich zuvor im Forum nachgesehen und ich habe keine Antwort auf meine Frage gefunden. Deshalb habe ich hier alles so ausführlich geschrieben.

Beste Grüße Suki



Re: [OT] Hinweis

Autor: gaby
Datum: 24.04.2012 19:43:58

> Also was ist nun, Tobias scheint nicht da zu
> sein. Bekomme ich evtl. von Euch eine Antwort auf
> meine wichtige Frage ?


Hallo,

Wenn niemand antwortet, kann das 3 Gründe haben:

Entweder ist die Fragestellung unverständlich, kein Code oder kein Link beigefügt.

- das war bei dir nicht der Fall. Du hast alles sehr ausführlich beschrieben.

oder es ist gerade niemand im Forum, weil unser Beruf, mit dem wir unsere Brötchen verdienen, uns gerade fordert,

oder es weiß wirklich niemand eine Lösung.
Auch wir sind nicht allwissend. ;-)


Grüße
gaby