selfhtml.de - Alles für den Webmaster!

 

Empfehlung:

wix.com

Kostenlose Homepage

Besuchen Sie auch:

Jobs:

AlienForm2 cgi Script funktioniert nicht

Autor: paul89m
Datum: 23.03.2010 17:15:19

Hallo an alle,

ich hab hier schon ein bisschen geforscht und auch Google ausgequetscht, aber nichts gefunden.

Ich habe vor einiger Zeit die Internetseite von meinen Eltern in Bearbeitung genommen und einige Sachen erfolgreich geändert. Nun sind wir Anfang des Jahres mit dem Webhosting von Strato zu Gerwan umgezogen.
Problem: Das von cgi Script funktioniert nicht mehr.
Wenn jetzt also das Formular ausgefüllt wurde, wird es nicht abgeschickt, sondern es erscheint eine Meldung:

Serverfehler!

Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist.

Fehlermeldung:
Premature end of script headers: af_ulf.cgi

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 500

Tue Mar 23 17:12:26 2010
Apache/2.0.54 (Debian GNU/Linux) mod_python/3.1.3 Python/2.3.5 PHP/4.3.10-16 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4

Da ich die Internetseite nicht geschrieben habe, kenne ich mich nicht mit dem Script aus.

Könnt ihr mir helfen? Bin schon total verzweifelt.
Gerne lade ich auch den Code des Scripts hoch.

Vielen Dank schon mal im Voraus.

GLG Paul



Re: AlienForm2 cgi Script funktioniert nicht

Autor: Matthias
Datum: 23.03.2010 18:41:03

> Hallo an alle,

Herzlich willkommen im Forum!


> ich hab hier schon ein bisschen geforscht und
> auch Google ausgequetscht, aber nichts gefunden.

Ist ja kaum zu glauben! Wenn ich Deine Fehlermeldung bei Google eingebe, bringt mir gleich das erste Suchergebnis einen Thread mit 3 möglichen Fehlerursachen. Wo lag Dein Problem bei der Bedienung von Google?


> Problem: Das von cgi Script funktioniert nicht
> mehr.
> Wenn jetzt also das Formular ausgefüllt wurde,
> wird es nicht abgeschickt, sondern es erscheint
> eine Meldung:
>
> Serverfehler!
>
> Die Anfrage kann nicht beantwortet werden, da im
> Server ein interner Fehler aufgetreten ist.
>
> Fehlermeldung:
> Premature end of script headers: af_ulf.cgi


Ich hab Dir mal das erste Suchergebnis verlinkt. Die Variante mit den Dateirechten auf 755 stellen, scheint mir am aussichtsreichsten.

Grüße

Matthias


Re: AlienForm2 cgi Script funktioniert nicht

Autor: paul89m
Datum: 23.03.2010 22:39:52

Vielen Vielen Dank!

Den link den du mir gegeben hattest, hatte ich auch schon, aber nicht wirklich verstanden, was das bedeuten soll.
Zugriffsberechtigungen waren bei mir auf 644 und nicht 755!^^


Aber dennoch schickt das Formular keine email an die im .txt Dokument angegebene mail adresse. Woran kann das liegen?

Hier mal ein auszug des Codes der Formular Seite, habe ich vielleicht wieder was über sehen? Bitte noch mal um Hilfe!^^

<form method="POST" action="../cgi-bin/af_ulf.cgi">


Alle für die Verlinkung angegebenen Dateien sind vorhanden und im beschriebenen Verzeichniss!

GLG
                       <input type="HIDDEN" name="_send_email" value="/html/cgi-bin/email_ulf.txt">
                       <input type="HIDDEN" name="_browser_out" value="/html/cgi-bin/output_ulf.html">
                       <input type="HIDDEN" name="_out_file" value="/html/cgi-bin/logfile_ulf.txt">